MD5
8594b9448833a5a0b66ca9bcb1795e32
SHA1
8ffaca592f49b5b22825ad37538faeecb07600b6
  • Анонимно
  • Скачан 217 раз
  • Metalink
  • QR

Общее

Количество файлов: 1

Описание

Помогите с хар-ками при отборе по документам

Процедура ВыгрузитьТоварыПоСпискуДоков(Т)
Таб=Новый ТаблицаЗначений;
Таб.Колонки.Добавить("Номенклатура",Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));
Таб.Колонки.Добавить("Характеристика",Новый ОписаниеТипов("СправочникСсылка.ХарактеристикиНоменклатуры"));
Таб.Колонки.Добавить("Идент",ОписаниеТиповС40);
Для Каждого Док Из СписокДоков Цикл
//ИмяРеквТоваров=ИмяРеквизитаТоваров(Док.Документ);
//ИмяРеквХарактеристик=ИмяРеквизитаХарактеристик(Док.Документ);
Для Каждого Стр Из Док.Документ.Товары Цикл
Тов=Стр.Номенклатура;
Харка=?(Стр.ХарактеристикаНоменклатуры=Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка(),Неопределено,Стр.ХарактеристикаНоменклатуры);
Идент=Тов.Код+":"+?(Харка=Неопределено,"",Харка.Код);
Если Таб.Найти(Идент,"Идент")=Неопределено Тогда
Нов=Таб.Добавить();
Нов.Номенклатура=Тов;
Нов.Характеристика=Харка;
Нов.Идент=Идент;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Т.ДобавитьСтроку(СформироватьРеквизит("СписокТоваров","Ок"));
Для Каждого Стр Из Таб Цикл
Харка=?(Стр.Характеристика=Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка(),Неопределено,Стр.Характеристика);
ВыгрузитьЭлемент(Т,Стр.Номенклатура,Харка);
КонецЦикла;
КонецПроцедуры

Список файлов

Ссылка: Код для блога или сайта: Ссылка для форума: